We did these basic IS-IS configurations on two routers which are directly connected via two interfaces:
R1 configuration:
ip address 1.1.1.1 255.255.255.255
ip router isis 1
!
interface FastEthernet1/0
ip address 192.168.12.1 255.255.255.0
ip router isis 1
!
interface FastEthernet1/1
ip address 192.168.21.1 255.255.255.0
ip router isis 1
!
router isis 1
net 49.0001.0000.0000.0001.00
R2 configuration
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip router isis 1
!
interface FastEthernet1/0
ip address 192.168.12.2 255.255.255.0
ip router isis 1
speed auto
duplex auto
!
interface FastEthernet2/1
ip address 192.168.21.2 255.255.255.0
ip router isis 1
speed auto
duplex auto
!
router isis 1
net 49.0001.0000.0000.0002.00
R1#show ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/20] via 192.168.21.2, 00:03:12, FastEthernet1/1
[115/20] via 192.168.12.2, 00:03:12, FastEthernet1/0
i L1 2.2.2.2 [115/20] via 192.168.21.2, 00:03:12, FastEthernet1/1
[115/20] via 192.168.12.2, 00:03:12, FastEthernet1/0
Neighborships are established for both Level-1 and Level-2:
Tag 1:
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa1/0 192.168.12.2 UP 8 R2.02
R2 L2 Fa1/0 192.168.12.2 UP 8 R2.02
R2 L1 Fa1/1 192.168.21.2 UP 7 R2.03
R2 L2 Fa1/1 192.168.21.2 UP 8 R2.03
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa1/0 192.168.12.2 UP 8 R2.02
R2 L2 Fa1/0 192.168.12.2 UP 8 R2.02
R2 L1 Fa1/1 192.168.21.2 UP 7 R2.03
R2 L2 Fa1/1 192.168.21.2 UP 8 R2.03
And equal cost load balancing occurs:
R1#show ip cef 2.2.2.2
2.2.2.2/32
nexthop 192.168.12.2 FastEthernet1/0
nexthop 192.168.21.2 FastEthernet1/1
Lets do basic reachability test:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/94/108 ms
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/94/108 ms
On multiaccess networks, IS-IS elects a designated intermediate system (DIS) router.It works like OSPF DR feature.But preemption is enabled by default and default priority is 64.If priorities are equal in multiaccess network, mac addresses will be used as tiebreaker.
R1#show clns interface f1/0
FastEthernet1/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 36 seconds
Routing Protocol: IS-IS (1)
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: R2.02
DR ID: R2.02 Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: R2.02
DR ID: R2.02 Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 992 milliseconds
Next IS-IS LAN Level-2 Hello in 7 seconds
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface f1/0
R1(config-if)#isis priority 127
R1(config-if)#
R1(config-if)#end
FastEthernet1/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 36 seconds
Routing Protocol: IS-IS (1)
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: R2.02
DR ID: R2.02 Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: R2.02
DR ID: R2.02 Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 992 milliseconds
Next IS-IS LAN Level-2 Hello in 7 seconds
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface f1/0
R1(config-if)#isis priority 127
R1(config-if)#
R1(config-if)#end
R1#show clns interface f1/0
FastEthernet1/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 46 seconds
Routing Protocol: IS-IS (1)
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 127, Circuit ID: R1.01
DR ID: R1.01 Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 800 milliseconds
Next IS-IS LAN Level-2 Hello in 2 seconds
FastEthernet1/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 46 seconds
Routing Protocol: IS-IS (1)
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 127, Circuit ID: R1.01
DR ID: R1.01
Level-1 IPv6 Metric: 10Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 127, Circuit ID: R1.01
DR ID: R1.01 Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 800 milliseconds
Next IS-IS LAN Level-2 Hello in 2 seconds
By default metric is 10 on all interfaces.For metrics greater than 63 metric-style wide command must be enabled:
R1(config-if)#isis metric 100
Warning: for metrics greater than 63, 'metric-style wide' should be configured on level-1-2, or it will be capped at 63.
R1(config-if)#router isis 1
R1(config-router)#metric-style wide
R1(config)#int f1/0
R1(config-if)#isis metric 100
R1(config-if)#int f1/1
R1(config-if)#isis metric 200
R1#show ip route isis
R1(config)#int f1/0
R1(config-if)#isis metric 100
R1(config-if)#int f1/1
R1(config-if)#isis metric 200
R1#show ip route isis
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/110] via 192.168.12.2, 00:00:02, FastEthernet1/0
i L1 2.2.2.2 [115/110] via 192.168.12.2, 00:00:02, FastEthernet1/0
Metric-style wide command should be enabled on all routers.If we remove the configuration, we lose the routes:
R1(config)#router isis 1
R1(config-router)#no metric-style wide
%Due to removing wide metrics, 'isis metric 100' configured on Fa1/0 is capped at 63
%Due to removing wide metrics, 'isis metric 200' configured on Fa1/1 is capped at 63
R1(config-router)#end
*Aug 18 19:26:13.503: ISIS-LR (1): 192.168.21.0/24: not aged out in LSP ix 7 same ver(14)
*Aug 18 19:26:13.507: ISIS-LR (1): 192.168.12.0/24: not aged out in LSP ix 7 same ver(14)
*Aug 18 19:26:13.507: ISIS-LR (1): 2.2.2.2/32: not aged out in LSP ix 7 same ver(14)
*Aug 18 19:26:13.507: ISIS-LR (1): 1.1.1.1/32: aged out in LSP[8/(20->21)]
*Aug 18 19:26:13.511: ISIS-LR (1): rem path: [115/80/120] via 192.168.12.2(Fa1/0) from 2.2.2.2 tg 0 LSP[8/20] from active chain (add to deleted chain)
*Aug 18 19:26:13.511: ISIS-LR (1): Enqueued to updateQ[1] for 1.1.1.1/32
*Aug 18 19:26:13.511: ISIS-LR (1): 192.168.21.0/24: aged out in LSP[8/(20->21)]
*Aug 18 19:26:13.515: ISIS-LR (1): rem path: [115/80/110] via 192.168.12.2(Fa1/0) from 2.2.2.2 tg 0 LSP[8/20] from active chain
*Aug 18 19:26:13.515: ISIS-LR (1): 192.168.12.0/24: aged out in LSP[8/(20->21)]
*Aug 18 19:26:13.515: ISIS-LR (1): rem path: [115/80/110] via 192.168.12.2(Fa1/0) from 2.2.2.2 tg 0 LSP[8/20] from active chain
R1(config-router)#no metric-style wide
%Due to removing wide metrics, 'isis metric 100' configured on Fa1/0 is capped at 63
%Due to removing wide metrics, 'isis metric 200' configured on Fa1/1 is capped at 63
R1(config-router)#end
*Aug 18 19:26:13.503: ISIS-LR (1): 192.168.21.0/24: not aged out in LSP ix 7 same ver(14)
*Aug 18 19:26:13.507: ISIS-LR (1): 192.168.12.0/24: not aged out in LSP ix 7 same ver(14)
*Aug 18 19:26:13.507: ISIS-LR (1): 2.2.2.2/32: not aged out in LSP ix 7 same ver(14)
*Aug 18 19:26:13.507: ISIS-LR (1): 1.1.1.1/32: aged out in LSP[8/(20->21)]
*Aug 18 19:26:13.511: ISIS-LR (1): rem path: [115/80/120] via 192.168.12.2(Fa1/0) from 2.2.2.2 tg 0 LSP[8/20] from active chain (add to deleted chain)
*Aug 18 19:26:13.511: ISIS-LR (1): Enqueued to updateQ[1] for 1.1.1.1/32
*Aug 18 19:26:13.511: ISIS-LR (1): 192.168.21.0/24: aged out in LSP[8/(20->21)]
*Aug 18 19:26:13.515: ISIS-LR (1): rem path: [115/80/110] via 192.168.12.2(Fa1/0) from 2.2.2.2 tg 0 LSP[8/20] from active chain
*Aug 18 19:26:13.515: ISIS-LR (1): 192.168.12.0/24: aged out in LSP[8/(20->21)]
*Aug 18 19:26:13.515: ISIS-LR (1): rem path: [115/80/110] via 192.168.12.2(Fa1/0) from 2.2.2.2 tg 0 LSP[8/20] from active chain
By default, both Level-1 and Level-2 operations are enabled on IS-IS routers.We can change this default behaviour:
R1#show isis neighbor
Tag 1:System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa1/0 192.168.12.2 UP 9 R2.02
R2 L2 Fa1/0 192.168.12.2 UP 8 R2.02
R2 L1 Fa1/1 192.168.21.2 UP 8 R2.03
R2 L2 Fa1/1 192.168.21.2 UP 7 R2.03
R1(config)#router isis 1
R1(config-router)#is-type level-1
R1#show isis neighbors
Tag 1:
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa1/0 192.168.12.2 UP 20 R1.01
R2 L1 Fa1/1 192.168.21.2 UP 9 R2.03
System Id Type Interface IP Address State Holdtime Circuit Id
R2 L1 Fa1/0 192.168.12.2 UP 20 R1.01
R2 L1 Fa1/1 192.168.21.2 UP 9 R2.03
We can redistribute routes into IS-IS.By default these routes are Level-2:
R1(config-router)#redistribute connected metric 10
R2#show ip route isis
1.0.0.0/32 is subnetted, 1 subnets
i L1 1.1.1.1 [115/110] via 192.168.12.1, 00:17:57, FastEthernet1/0
10.0.0.0/24 is subnetted, 2 subnets
i L2 10.10.10.0 [115/110] via 192.168.12.1, 00:00:01, FastEthernet1/0
i L2 10.10.11.0 [115/110] via 192.168.12.1, 00:00:01, FastEthernet1/0
1.0.0.0/32 is subnetted, 1 subnets
i L1 1.1.1.1 [115/110] via 192.168.12.1, 00:17:57, FastEthernet1/0
10.0.0.0/24 is subnetted, 2 subnets
i L2 10.10.10.0 [115/110] via 192.168.12.1, 00:00:01, FastEthernet1/0
i L2 10.10.11.0 [115/110] via 192.168.12.1, 00:00:01, FastEthernet1/0
R2#show ip route isis
1.0.0.0/32 is subnetted, 1 subnets
i L1 1.1.1.1 [115/110] via 192.168.12.1, 00:18:16, FastEthernet1/0
10.0.0.0/24 is subnetted, 2 subnets
i L1 10.10.10.0 [115/110] via 192.168.12.1, 00:00:04, FastEthernet1/0
i L1 10.10.11.0 [115/110] via 192.168.12.1, 00:00:04, FastEthernet1/0
We can summarize these routes:
R1(config-router)#summary-address 10.10.10.0 255.255.254.0 level-1-2 metric 5
1.0.0.0/32 is subnetted, 1 subnets
i L1 1.1.1.1 [115/110] via 192.168.12.1, 00:24:07, FastEthernet1/0
10.0.0.0/23 is subnetted, 1 subnets
i L1 10.10.10.0 [115/105] via 192.168.12.1, 00:00:02, FastEthernet1/0
No comments:
Post a Comment