Thursday, September 15, 2011

Cisco IOS XR MPLS TE Fast Reroute Example

Cisco IOS XR MPLS TE Fast Reroute Example

In this example we will show Cisco IOS XR MPLS Traffic Engineering Fast Reroute configuration briefly.Here is our basic topology for this configuration:



We have configured MPLS TE tunnel between R5 and R1.
Configuration on head end router:

router ospf 1
 router-id 5.5.5.5
 area 0
 mpls traffic-eng
 interface GigabitEthernet0/1/0/0

mpls traffic-eng
 interface GigabitEthernet0/1/0/0

rsvp
 interface GigabitEthernet0/1/0/0

explicit-path name to-router5
 index 1 next-address strict ipv4 unicast 4.4.4.4
 index 2 next-address strict ipv4 unicast 3.3.3.3
 index 3 next-address strict ipv4 unicast 5.5.5.5

interface tunnel-te5
 ipv4 unnumbered Loopback0
 load-interval 30
 autoroute announce
 destination 5.5.5.5
 fast-reroute
 path-option 1 explicit name to-router5
 path-option 2 dynamic

We will protect the link between R4(4.4.4.4) and R3(3.3.3.3).When the link between R3 and R4 fails, all MPLS TE traffic will pass through Router2(2.2.2.2) until the new path converges(because we have secondary dynamic path option).

Configuration on Point of Local Repair router(router4):

router ospf 1
 router-id 4.4.4.4
 area 0
 mpls traffic-eng
 interface GigabitEthernet0/1/0/0
 interface GigabitEthernet0/1/0/1
 interface GigabitEthernet0/1/0/2

mpls traffic-eng
 interface GigabitEthernet0/1/0/0
 interface GigabitEthernet0/1/0/1
  backup-path tunnel-te 23
 interface GigabitEthernet0/1/0/2

rsvp
 interface GigabitEthernet0/1/0/0
 interface GigabitEthernet0/1/0/1
 interface GigabitEthernet0/1/0/2

explicit-path name backupto-r3
 index 1 next-address strict ipv4 unicast 2.2.2.2
 index 2 next-address strict ipv4 unicast 3.3.3.3

interface tunnel-te23
 ipv4 unnumbered Loopback0
 load-interval 30
 destination 3.3.3.3
 path-option 1 explicit name backupto-r3


RP/0/RSP1/CPU0:Router4#show mpls traffic-eng fast-reroute database
LSP midpoint FRR information:
LSP Identifier                Local  Out Intf/        FRR Intf/        Status
                              Label  Label            Label                  
----------------------------- ------ ---------------- ---------------- -------
5.5.5.5 5                 143987 Gi0/1/0/1:16014      tt23:16015         Ready

Sunday, September 4, 2011

Cisco IOS XR Ospf Sham-link Configuration Example

To provide the backdoor link of CE routers wait as a backup link we can enable sham-link on PE routers.Here is the configuration on a IOS XR PE router:

router ospf 100
vrf test
redistribute bgp 1
address-family ipv4 unicast
area 0
sham-link 1.1.1.1 2.2.2.2 ==>1.1.1.1 is a local loopback ,2.2.2.2 is a remote loopback of PE routers
!
interface GigabitEthernet0/1/0/1.1

router bgp 1
vrf test
rd 1.1.1.1:100
address-family ipv4 unicast
redistribute connected ==>redistribute connected or network command for shamlink loopbacks
redistribute static
redistribute ospf 100

RP/0/RSP0/CPU0:TESTROUTER#show ospf vrf test neighbor



Neighbors for OSPF 100, VRF test

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2       0     FULL/  -        00:00:36    2.2.2.2       OSPF_SL0
Neighbor is up for 00:19:28
1.1.1.10        1     FULL/DR         00:00:31    10.10.10.2      GigabitEthernet0/1/0/1.1
Neighbor is up for 01:02:03

Total neighbor count: 2


CPE configuration:

router ospf 100
router-id 1.1.1.10
network 1.1.1.10 0.0.0.0 area 0     è lo0 ip address of CPE router
network 10.10.10.2 0.0.0.0 area 0 è connection to PE-1(Vlan100)
network 10.10.11.1 0.0.0.0 area 0 è backdoor link of CPE routers

10.10.15.0/24 is a connected interface`s IP Prefix on CPE-2 router which is attached to area 0.

When the backdoor link is active and Ospf neighborship is established between CPE routers, CPE-1 sees this ip route through the backdoor link.

Lets close the backdoor link...

IP routing table entry for 10.10.15.0/24 on CPE router before the sham-link is active on PE routers:


CPE-1#show ip route ospf
O IA    10.10.15.0/24 [110/50] via 10.10.10.1, 00:00:02, Vlan100

Intra area routes come as inter area routes when they are redistributed from BGP to OSPF.


After sham-link configuration:

CPE-1#show ip route ospf


10.10.15.0/24 [110/2] via 10.5.18.5, 00:12:00, Vlan100

We see that, after we had configured shamlink between PE-1 and PE-2, previously coming inter-area routes became intra area routes as they were originated.This can prevent choosing backdoor link instead of Mpls VPN network.