Basic Cisco RIP Version 2 Configuration Example:
Here is the configuration example topology for RIP version 2:
Configurations of routers for RIP version 2:
R1
!
interface Loopback0
ip address 192.168.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.13.1 255.255.255.0
!
router rip
version 2
network 192.168.0.0
network 192.168.12.0
network 192.168.13.0
no auto-summary
R2
!
interface Loopback0
ip address 192.168.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.24.2 255.255.255.0
!
router rip
version 2
network 192.168.0.0
network 192.168.12.0
network 192.168.24.0
no auto-summary
R3
!
interface Loopback0
ip address 192.168.0.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.13.3 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.34.3 255.255.255.0
!
router rip
version 2
network 192.168.0.0
network 192.168.13.0
network 192.168.34.0
no auto-summary
R4
!
interface Loopback0
ip address 192.168.0.4 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.24.4 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.34.4 255.255.255.0
!
router rip
version 2
network 192.168.0.0
network 192.168.24.0
network 192.168.34.0
no auto-summary
Lets check the routing table of R1 for RIP version 2 routes:
R1#show ip route rip
R 192.168.24.0/24 [120/1] via 192.168.12.2, 00:00:14, FastEthernet0/0
R 192.168.34.0/24 [120/1] via 192.168.13.3, 00:00:03, FastEthernet0/1
192.168.0.0/32 is subnetted, 4 subnets
R 192.168.0.2 [120/1] via 192.168.12.2, 00:00:14, FastEthernet0/0
R 192.168.0.3 [120/1] via 192.168.13.3, 00:00:03, FastEthernet0/1
R 192.168.0.4 [120/2] via 192.168.13.3, 00:00:03, FastEthernet0/1
[120/2] via 192.168.12.2, 00:00:14, FastEthernet0/0
Since we have configured basic RIP version 2 with no additional features, all timer, filters etc are stay as default:
R1#show ip protocols
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
FastEthernet0/1 2 2
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
192.168.0.0
192.168.12.0
192.168.13.0
Routing Information Sources:
Gateway Distance Last Update
192.168.13.3 120 00:00:14
192.168.12.2 120 00:00:27
Distance: (default is 120)
Lets debug the RIP version 2 packets:
R1#debug ip rip
RIP protocol debugging is on
*Mar 1 00:36:03.275: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.1)
*Mar 1 00:36:03.275: RIP: build update entries
*Mar 1 00:36:03.275: 192.168.0.1/32 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:36:03.279: 192.168.0.3/32 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:36:03.279: 192.168.13.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:36:03.279: 192.168.34.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:36:10.055: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/1 (192.168.13.1)
*Mar 1 00:36:10.055: RIP: build update entries
*Mar 1 00:36:10.055: 192.168.0.1/32 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:36:10.059: 192.168.0.2/32 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:36:10.059: 192.168.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:36:10.059: 192.168.24.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:36:10.999: RIP: received v2 update from 192.168.13.3 on FastEthernet0/1
*Mar 1 00:36:10.999: 192.168.0.3/32 via 0.0.0.0 in 1 hops
*Mar 1 00:36:11.003: 192.168.0.4/32 via 0.0.0.0 in 2 hops
R1#
*Mar 1 00:36:11.003: 192.168.24.0/24 via 0.0.0.0 in 2 hops
*Mar 1 00:36:11.007: 192.168.34.0/24 via 0.0.0.0 in 1 hops
Lets test the reachability:
R1#ping 192.168.0.4 source 192.168.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.4, timeout is 2 seconds:
Packet sent with a source address of 192.168.0.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/72/92 ms
No comments:
Post a Comment